Show full version of the posting: Initial view of drawing

luisfnunes
27.05.2017, 11:02

I don't know why but it started to happen to me that everytime i now open a drawing (DWG) the initial view is not an updated one. Let me explain: Suppose i start a new blank drawing.. it opens up with a blank canvas of let's say from point (0,0) to point (420,270).Now if i draw something in it, let's say a line from (1000,1000) to (1250,1250), do a zoom extents and save the drawing, the file preview in explorer get's updated and shows a diagonal line... but when i reopen that drawing, it will keep showing me the (0,0);(420,270) área.I have to do a zoom extents to get the same view as i last left it..Same thing happens if a use viewports.. i save the drawing with 2 vertical viewports.. the preview shows exactly that, but when i reopen the drawing.. voilá! ... back to one viewport at a view i had like .. last week!...does anyone have this same issue going on too?I have already unisntalled and reinstalled the cad program (ZWCAD 2014+)i have already went through the system variables and there's no one that reports to something like this that aren't read-only...any ideas on why it happens?thanks

Kent Cooper
30.05.2017, 14:49

Do you have something, that is run through acaddoc.lsp on opening every drawing, or perhaps at the other end, some custom closing-a-drawing-routine, that automatically Zooms to the drawing Limits?  It would look something like: (command "_.zoom" (getvar 'limmin) (getvar 'limmax))

luisfnunes
30.05.2017, 16:38
Thanks for your reply.No i don't have any routine calling a zoom limits.I have even already tried uninstalling and reinstalling and prior to adding any of my own routine menus, and it happens the same.i'm beginning to think that it has something to do with the last Windows 10 creators update that it 'created' some sort of incompatibility with the program and this happens.Also happens with viewport creation... every time i try to create a viewport on a drawing, let's say two vertical viewports, the program does create them but fails to activate them. I have to go through View-Viewports-1 Viewport and again view-viewports-2 viewports so that the viewports can become active and i can use them...:\

John Connor
30.05.2017, 16:54
We are talking about ZWCAD 2014 are we not?

luisfnunes
31.05.2017, 10:58

yes we are.ZWCAD+ 2014 SP1 ProVersion number: 2014.04.27 (21135)

Kent Cooper
31.05.2017, 17:09
[QUOTE=luisfnunes]
yes we are.ZWCAD+ 2014 SP1 ProVersion number: 2014.04.27 (21135)[/QUOTE]
Since this thread is in the AutoCAD Forum (rather than, say, the CAD - general Forum), am I right to assume that ZWCAD (I'm not familiar with it) is some kind of overlay software built on AutoCAD?  And that therefore the issue at least might involve something in AutoCAD as I assumed before?  If not, ignore my suggestion, since it is AutoCAD-specific.

luisfnunes
31.05.2017, 18:09
i have posted here because they are very similar programs and was hoping that it was some issue that other users were experiencing (even though using AutoCAD and not ZWCAD.

John Connor
31.05.2017, 23:37

ZWCAD is a Chinese AutoCAD-clone not an add-on of some kind.

luisfnunes
01.06.2017, 10:07

you may cal it a 'clone' but the fact from my experience is that for under 400€ i have been using it for over 3 years and i don't need AuitoCAD 2017 Map that i have here where i work...It's much more lighweight, fast, easy.It stared giving me these 2 bugs now and i'm convinced it's because of Windows creators update.I guess i'll have to upgrade it to ZWCAD 2017.

John Connor
01.06.2017, 11:30
It's still a clone.  A side-by-side comparison of the layout and features would confirm that simple and unavoidable fact.Well your only other options are...1. Reset all settings (assuming that is possible in ZWCAD) or...2. Roll back your system using a Restore point that pre-dates the last Windows update.

luisfnunes
01.06.2017, 11:45

i don't and won't argue about that... it was a long judicial battle that ended with the courts saying that in fact it wasn't a clone.Then outside of courts they (Autodesk and ZWSoft) agreed to change a few things.But that's all i know.My hope was that it was due to some system variable or something because as far as i have realized, the problem resides with the program failing to write down in the drawing upon closure the value of VIEWCTR and VIEWSIZE even thought the file preview thumbnail is correctly generated.Upon opening it seems that those variables are somehow reset to default vaules:Command: VIEWCTRVIEWCTR = 210.00,170.71,0.00 (read only)Command: VIEWSIZEVIEWSIZE = 331.82 (read only)I'm not roling back my OS because of this. I'll have to upgrade the ZWCAD version (it'll cost me less than 100€ to do so.......)
luisfnunes2017-06-01 11:47:38

John Connor
01.06.2017, 14:53
Does ZWCAD, like AutoCAD, have the option to reset all system variables to their default settings?  If "yes" then that is one possible option you still have available to you.  And it costs nothing except a small amount of time.If you have, as your profile states, use of AutoCAD 2016 why are you even bothering with ZWCAD 2014?  What do you gain by using a Chinese CAD program that is two years older then the version of AutoCAD that you have?  Is the AutoCAD program a pirated copy?

John Connor2017-06-01 14:56:00

luisfnunes
02.06.2017, 11:09
i can't post any more without pending approval?

luisfnunes
02.06.2017, 11:14
I have uninstalled it, ran through the HDD, Regedit and deleted everything related to ZWCAD.Reinstalled it.Problem remains. So i think it has to do with the VB code and the save center view and view size of drawing upon closure.The AutoCAD Map 2016 is Licenced.The problem is of course the very overpriced price of AutoCAD... it only allows a company to obtain a very limited number of licences don't you agree?We have a network instalation and i found myself many times not being abble to work because there was no licence available so.. for 300€ i decided to buy myself a licence. And i can tell you that it was one of the best things i bought so far!

luisfnunes
02.06.2017, 11:15
As for the 'Chinese' CAD program... have you ever tried ZWCAD+ 2014 Pro ?Do you like a CAD program that takes about 1GB of RAM just to be opened with an empty drawing?... ZWCAD takes less than 500MB of RAM with a 30MB drawing opened !Do you like a CAD program that loads up so many addons that you just never use...?...And for over 5000 Dollars you get a program that has little bugs like the 'Chinese CAD' program that costs 1/10th of the price, like having to disable the Aero preview of the Windows task bar in order to have the autocad window restored in a proper way and avoid the very annoying maximize *every* time you need to minimize...In short... i kind of liked more the AutoCAD 2004 than all its predecessors. It was much more simple, more lightweight, faster opening and closing and working with than now, but that's just my oppinion and mainly is why i like ZWCAD so much more
luisfnunes2017-06-02 11:17:40

John Connor
02.06.2017, 13:27
Yes, I have tested a number of CAD programs including ZWCAD.  That's my job.  Right now I am testing the latest version of BricsCAD V17 Platinum.  I've been running it for a week now.Fortunately for me I work for a company that does not skimp when it comes to buying hardware.  My system can more than handle anything that is thrown at it.  And since I run a very lean system I rarely if ever have a problem with a CAD program crashing it.  I also keep backups of all profiles, cui's, and system variable settings.Every piece of software has its own share of bugs; some more than ever.  Users though need to be diligent when it comes to installing updates and hot fixes.