Show full version of the posting: low memory error

Zuhaib
03.03.2016, 05:58
Anyone can teach me, What is the solution this problem?????????????

John Connor
03.03.2016, 11:38
I believe this is more of a Windows limitation than it is an AutoCAD issue.How much physical RAM is installed in your computer?Why does it show you are using AutoCAD 2010 in your profile but the image above clearly shows you are using AutoCAD 2015?What OS are you running?Is this a 2D or 3D drawing?What is the file size of the drawing?Are there any xrefs or images attached?Have you run the following commands on the drawing:Overkill-Puge (RegApps)-Purge (All)Audit (fix errors)

Zuhaib
03.03.2016, 11:55
Sorry, I did not update my profile. my current auto Cad version is 2015 and my RAM is of 3 gb in operating system of windows 7 32 bits with the processor of  core 2 quad.

John Connor
03.03.2016, 12:46
There's your problem.  Your system does not have enough resources (i.e. - RAM) to handle what you are trying to do.What do you have for a graphics card or does your computer have an onboard graphics chip?Is this a 2D or 3D drawing?How large is the file size?What else is running in the background (ex. - antivirus program, browser, etc.)?I don't ask questions just to hear myself speak.  I ask questions to diagnose a problem and come up with a solution.



John Connor2016-03-03 12:51:55

John Connor
03.03.2016, 13:49
I don't have all day to waste.Try this.  Shut down all non-essential programs running in the background (ex. - antivirus, browser, MS Office type programs such as Word or Excel, etc.).  Next, test the drawing you had the problem with.  Does the problem return?  If it doesn't then continue working.  If it does return close AutoCAD and disable all the bells and whistles that are part of Windows 7.  Test again using the same drawing.  Does the problem return?  If it doesn't then continue working.  If it does then you have to make a couple of changes.A Win7 32-bit computer can only address, theoretically, at most 4GB of RAM.  It will never fully address all the installed RAM (at best it will address 3.5GB of the 4)  Your system has 3GB.  Upgrade to 4GB.  Next, read the article found in this link to activate the 3GB switch in Win7.https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/How-to-enable-a-3GB-switch-on-Windows-Vista-Windows-7-or-Windows-XP-s.htmlNow test the result of these changes.  Does the problem return or not?If it does there is only one other tweak I can think of you could make to your computer and that would be to increase the size of the virtual memory paging file and set the minimum and maximum values to the same setting

800x600

rather than letting Windows manage it for you.  This tweak will set aside a contiguous portion of your hard drive for paging data in and out of memory and should help speed things up in the process.