Show full version of the posting: Reset UCS to default position and remain so

robinrobinsonsa
09.02.2017, 10:07
My UCS keeps changing positions when alternating between
views.  I have to constantly reset it to
WCS. How do I reset it to it's original position (WCS) to remain so?

John Connor
09.02.2017, 11:33

Could it be you have Dynamic UCS enabled?

robinrobinsonsa
09.02.2017, 19:11
I've tried a few settings actually and lost track of what I've had on / off.  My last resort was to copy and paste the whole drawing into into a new file which seems to have resolved the issue, nonetheless I'd still be interested to know what the issue is. I'll post again if the i pick up the problem again.  Thanks for your assistance.

John Connor
09.02.2017, 19:20
 Did you try this:"At the command line, type "UCS" then
choose the "World" option. Next type "Plan" and choose
"World".

robinrobinsonsa
09.02.2017, 21:36
Yes, I've tried that.  The UCS resets itself to the World position where I'd like it to remain, then on changing views reverts to the other position.

Kent Cooper
09.02.2017, 21:54
[QUOTE=John Connor]
Could it be you have Dynamic UCS enabled?[/QUOTE]
 It sounds like exactly that.  Check the UCSDETECT System Variable.

robinrobinsonsa
12.02.2017, 07:32
Just looking back at previous files for this drawing (I save drawings as a new file each time I work on them as backups), Dynamic UCS was on in each file so I don't think that was the issue.  The only "out of the ordinary" thing that has happened over the last few weeks is that my laptop has spontaneously shutdown a few times due to an insufficient power supply having used a smaller adapter from one of my old laptops until I replaced the original one the other day so maybe the file was corrupted??

robinrobinsonsa
14.02.2017, 07:36
Okay, I'm experiencing the same problem again in my TOP VIEW.  The only thing that I've done that might have something to do with the change is opening BLOCK EDITOR, COPYING some of the content within the BLOCK, PASTING IT WITH A BASE POINT as another BLOCK within the BLOCK and closing it.  I did it this way because as far as I know one can't CREATE A BLOCK within a BLOCK. Anyway, whatever the case is that is all that I've done that has something to do with this problem.

John Connor
14.02.2017, 11:55
A block within a block is a nested block and you don't have to use the block editor to create a nested block. 

robinrobinsonsa
21.02.2017, 08:57
I'm having the same issue again, none of the above suggestions have helped.  Any other advice please?  Only the TOP VIEW seems to be affected.  The only thing that I can recall doing around "the time of change" is using the PRESSPULL command.

John Connor
21.02.2017, 11:17
The problem has nothing to do with the PRESSPULL command.Try this...Click View menu 3D ViewsPlan ViewWorld UCS. How much AutoCAD training have you had?

John Connor2017-02-21 12:35:22

robinrobinsonsa
20.03.2017, 09:20
Hi JohnI only saw this message now, notifications were being sent to an old email address.I have tried your suggestion to no success.  To reset the UCS to the default position I can do so by typing UCS, and resetting it to the WORLD position but then the minute I reopen that view I have the same problem.  The UCS only seems to change sometimes when using the PRESSPULL command where the depth of the concerned entity is not at zero. I can just reset the UCS in the affected view each time to the WORLD / default position but it's a waste of time.I'm self taught with this program but I think I know my way around it by now, seven years later, still learning though and always eager to do so.

John Connor
20.03.2017, 12:48
Is Dynamic UCS disabled?

robinrobinsonsa
20.03.2017, 14:03
It's on at the moment.

John Connor
20.03.2017, 14:11
Have you tested with it disabled?  Otherwise I'm inclined to think it is a problem with the operator and not necessarily with AutoCAD.