Show full version of the posting: System variable for auto-selecting layers?

EnvisionMan
05.01.2015, 07:17
Using AutoCAD 2012.  When I open the layer manager box, I often hit the first letter of the layer I want to find. When a drawing has 100 layers, scrolling for the layer can be tedious.  For example, if I am looking for the Text_Elec layer, I hit the 'T' button to quickly scroll down to that section.  This saves time, but causes a minor problem as well.When you hit the 'T' button, it also automatically changes the active layer the first layer starting with the letter T.I love using the shortcut to get to the layers I want to look at.  But I don't like that it changes the active layer automatically.Does anyone know a way to turn this off?Thanks.EnvisionMan

John Connor
05.01.2015, 12:02
Have you looked into using layer filters?

EnvisionMan
05.01.2015, 18:40
Yes... I have considered using filters, but the challenge is I get files from builders and surveyors that have the layers set up (with no filters) and I would have to set them up constantly each time.  I use filters on my own custom stuff (plus I only use about 20 layers on my own drawings) but my challenge is with the drawings other people send me.

John Connor
05.01.2015, 20:27
I cannot duplicate your problem unless I right-click and select either Set current or Isolate selected layers.

EnvisionMan
06.01.2015, 01:35
Here is what I am doing, step by step:In my menu bar is my dropdown box to select layers.  When I click the little black arrow, all layers show up below.  If I click a random letter (let's say the letter 'T') the layers scroll down to the T's.Without doing anything else, if I click back on my model space, the layer is now changed to the first layer with a letter 'T'... for my current drawing, it is layer TB_DIM.Sometimes I just want to freeze or turn off a layer.  I don't want to change the active layer, just manipulate the layers.  So if I wanted to freeze layer "Text_Elec" I would normally click the pull-down arrow for layers, hit the 'T' to get me close to the layer I want to adjust, freeze the appropriate layer, and then click back on model space to get back to work.  But during the process, I will have changed the current layer to the first layer in the T's (for me it is the 'Tables' layer).I don't want to change the active layer.  Seems like there should be a variable for this... allow me to hit letters to move quickly in my layers, but not change the active layer.Maybe not, though... sometimes I get greedy with my time.

John Connor
06.01.2015, 13:58
Once again I am unable to duplicate your problem following the steps you have outlined.  You must be doing something else that you are not aware of.

EnvisionMan
06.01.2015, 19:37
Try this:1. make '0' the active layer2. while in model space, use your mouse to select the drop-down menu for layer controls (this is the box that shows the light bulb, the sun, the VP sun, the padlock, the color, and the layer). This is done by clicking the little black triangle.3. with your keyboard, click the letter 'T'.  This will quickly scroll the menu down to the layers starting with 'T'4. with your mouse, click back onto the model space area.Assuming you have a layer that starts with the letter 'T', your active layer should no longer be '0', but will be the first layer starting with the letter 'T'.If no one else's computer does this, then my computer is set up weird.  I would prefer my active layer NOT change when I click letters with my keyboard (while the layers menu is pulled down).Thanks for trying.

John Connor
07.01.2015, 14:33
Sorry....it does not do that on my computer.  You have a weird version of AutoCAD it seems.Note that I could only test this in AutoCAD 2014 and 2015.
John Connor2015-01-07 14:38:01