CAD Forum - Database of tips, tricks and utilities for AutoCAD, Inventor and other Autodesk products [www.cadforum.cz]
Czech English Deutsch
Login/Register:
 Visitors: 2287 
RSS tips RSS channel - CAD tips
RSS discussion RSS channel - CAD discussion

Discussion Discussion forum

HelpCAD discussion

CAD Forum - Homepage CAD discussion forum - ask any CAD-related questions here, share your CAD knowledge on AutoCAD, Inventor, Revit and other Autodesk software with your peers from all over the world. To start a new topic, choose an appropriate forum.

Please abide by the rules of this forum.

How to post questions: register or login, go to the specific forum and click the NEW TOPIC button.
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

The information that you provide in this form will make up your forum profile which can be viewed by other forum members. Your email address will only be visible by forum admin and moderators and will be used to send you Forum Notifications. To cancel your account, use the page Opt-out or contact webmaster@cadforum.cz.

Bindtype and its usage

 Post Reply Post Reply
Author
EngiMan View Drop Down
Newbie
Newbie


Joined: 04.Jan.2019
Location: Poland
Using: AutoCAD 2013/15/19, Inventor 2015
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote EngiMan Quote  Post ReplyReply Direct Link To This Post Topic: Bindtype and its usage
    Posted: 08.Feb.2019 at 16:48
Hi.
I've stumbled upon "_bindtype" system variable, which kind of surprised me. I just can't find any use for it and it works differently than I would think it should. 

The only thing it seems to change is the default option while binding a whole Xref file to another drawing:
_xr -> rightclick .dwg xref file -> bind -> "Bind" or "Insert" options.

On the other hand when you try to bind separate parts of an Xref it doesn't seem to do anything:
_xbind -> choose .dwg file -> choose Layers or a block for example -> "Add" -> OK.

Even with _bindtype = 1, which is a "Merge" option it actually doesn't merge the layers. All the layers which had been bound this way or objects drawn on some layers and bound to new drawing keep their separated names and $X$ numbering.

Do you know of any other way this variable comes into play? Also, is there any other way of binding parts of an xref into a drawing and merging layers besides going through them manualy and merging them in Layers Palette or manualy changing their names in order to break their connections to the source drawing?

Side question:
What I also noticed while using Design Cented (_dc) this time is that when I insert an object using it the layers palette doesn't update newly imported layers untill I save the file. "Refresh" button in the palette doesn't update it either. It would be great to be able to see/use layers without saving a drawing just in case. Any solution to this problem? (_regen doesn't work either btw.)
Back to Top

Related CAD tips:


 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0,063 seconds.